"«" ("& laquo ;") character etc. are being double-escaped and garbled

Started by Private User on Tuesday, November 30, 2010


Related Projects:

Showing all 20 posts
Private User
11/30/2010 at 9:00 PM

In the sentences where the left and right angle quotes (« or ») are used as arrows (e.g. http://www.geni.com/tr8n/phrases/view?translation_key_id=228666), when you right-click for in-line translation, the "«" character is changed into its HTML entity "& laquo ;".

Once the translation is submitted, the ampersand "&" in the HTML entity is being turned into its own HTML entity so that the garbled text reads "& amp ; laquo ;" instead of "«".

This doesn't occur if you don't do in-line translation, i.e. click "add your own translation" on a phase's own page.

(N.B. I put the spaces in "& laquo ;" to make sure it was displayed literally, not as its HTML entity - I'm not sure how the discussion form is handled and didn't want it garbled again. It might prove my point but would be difficult to understand.)

11/30/2010 at 10:35 PM

I usually just Copy-Paste the "«" symbol from English original to my translation. Then mostly it works well.

P.S. In some cases even the quotes marks " " or „ “ are garbled in translation result.

<private> Bračko
12/1/2010 at 12:18 AM

In Serbian language we do not have " " quotes marks, we have only „ “.

Private User
12/2/2010 at 3:21 AM

Yes, Lauri, I've been doing that as a workaround. It's simple enough but a bit annoying. :)

Private User
12/2/2010 at 11:05 AM

This is fixed now.

Private User
12/2/2010 at 1:58 PM

Just tried translating http://www.geni.com/tr8n/phrases/view?translation_key_id=228570&amp... which you can see is garbled.

If you go back into the translation (inline) and resave without changing anything, each time the & is turned into &amp; and it breaks the HTML entity before it, leading to a string of &amp;amp;amp...

Doesn't seem fixed yet. :(

Private User
12/2/2010 at 1:59 PM

P.S. The translation I gave above I voted down so it could be displayed from that link but wouldn't interfere with the proper site. I'll delete it once this is resolved.

Private User
12/2/2010 at 2:00 PM

Oh, and P.P.S., I suppose, re one of the other discussions, this problem happens both in Firefox and Chrome. I've purged IE from my life so can't test. It's definitely a problem with server-side script processing and wrongly escaping the contents of the translation form.

Private User
12/2/2010 at 2:09 PM

It works for me. I'm on Windows using Chrome.

Private User
12/2/2010 at 9:04 PM

Hmmm... I use Windows (tried XP, Vista and 7, matter of fact) and Chrome (also tried Firefox) too but it still doesn't work.

I find that recently (unlike the first few months of Tr8n), whenever I enter a character such as " < > « » or „ “, it is garbled.

The character breaks into its entity name, then the ampersand in the entity name is broken into its entity name, ad infinitum.

Regardless whether I enter the character itself (copy-paste) or its entity, the result breaks the ampersand every successive time the translation is edited.

This applies to both inline and non-inline translating, I've noticed.

Private User
12/2/2010 at 9:06 PM

Additionally, I can't use < b > < / b > in translations any more, because the angle brackets are broken into & lt ; and & gt ; , which are then broken in the same way as above.

Private User
12/2/2010 at 9:12 PM

Yeah, very frustrating. I think they changed their phaser.

Private User
12/2/2010 at 9:14 PM

This could be more of an issue for Amos Eagle Elliston to solve.

12/3/2010 at 4:21 AM

Private User Thanks to giving us NEW BUG
After opening your link:
in new window or tab (of FireFox) my Geni was switched over to German...
and next time I opened also "Amos Eagle Elliston" profile in German!!!

Some bug with Cookies?

Private User
12/3/2010 at 6:01 AM

No, I deliberately included "locale=de" in the link so that my German translation would be displayed. When you select a new locale, it changes your language to that. You have to reselect your prefered language in the usual way to reset. Seems valid enough to me...

12/3/2010 at 12:08 PM

We're looking into this issue.

Private User
12/3/2010 at 1:28 PM

Thanks Amos!

Private User
12/3/2010 at 4:22 PM

Great, thanks Amos.

Private User
12/3/2010 at 11:42 PM

An alternative fix for the bold issue would be to allow [bold:] anywhere.

12/17/2010 at 2:56 AM

Message for Kit Burton- Senior...are you the person researching the Sheargold ancestry? If so please contact me at boccaccio3@aol.com

Showing all 20 posts

Create a free account or login to participate in this discussion